Results 1 to 10 of 10

Thread: Email password not being saved correctly

  1. #1
    desh is offline Junior Member
    Join Date
    Feb 2012
    Posts
    4

    Default Email password not being saved correctly

    Hello,

    I am having trouble configuring my Outgoing Mail Configuration. I am trying to setup an SMTP mail server. When I initially enter my password, I am able to send a test email with no problem at all. However, when I have the password and try sending a test email, I get a password error (in the sugarcrm log). When I click "Change Password" and type in the same password again, it works. Then when I save it, once again it does not work.

    It appears that the password is not being saved correctly. Any assistance or suggestions to try to solve this would be greatly appreciated.

    Thank you,

    Suhas.

  2. #2
    Angel's Avatar
    Angel is offline Sugar Community Member
    Join Date
    Jul 2005
    Location
    Los Angeles
    Posts
    5,205

    Default Re: Email password not being saved correctly

    There appears to be a bug in Sugar pertaining to the Email Settings page in the Admin control panel which may be affecting you. As far as I can tell, just about every version of Sugar from 6.4 to 5.5 have the same problem.

    Anyway, the issue at hand is that it URL decodes some characters before it saves the value. In my case, I stumbled upon the problem because the user name included a "+" symbol. It refused to authenticate although everything was correct. Deeper investigation of the problem revealed that Sugar was saving the "+" as a " " (space). Thus, when it attempted to login to the SMTP server, the login information was indeed wrong because it wasn't sending the "+" symbol. I was fortunate that I could replace the "+" with a "@" but it is something worth looking at if you are using non-alphanumeric values in the user or password portion. It is possible it does the same for other characters.
    Regards,

    Angel Magaña
    Technical Solutions Architect
    Co-Author: Implementing SugarCRM 5.x (Packt Publishing -- Sept. 2010)
    Blog: http://cheleguanaco.blogspot.com.
    Twitter: @cheleguanaco.

  3. #3
    desh is offline Junior Member
    Join Date
    Feb 2012
    Posts
    4

    Default Re: Email password not being saved correctly

    Thank you very much Angel. I have used all alphas, and now I tried just using numerics with no luck.

    I will try using some special characters to see if these do save correctly.

    Cheers,

    Suhas.

  4. #4
    Ramblin is offline Sugar Community Member
    Join Date
    May 2010
    Posts
    199

    Default Re: Email password not being saved correctly

    Quote Originally Posted by desh View Post
    Thank you very much Angel. I have used all alphas, and now I tried just using numerics with no luck.

    I will try using some special characters to see if these do save correctly.

    Cheers,

    Suhas.
    Did you ever get this issue resolved?

    I am having the same issue now

    Richard

  5. #5
    Ramblin is offline Sugar Community Member
    Join Date
    May 2010
    Posts
    199

    Default Re: Email password not being saved correctly

    Quote Originally Posted by Angel View Post
    There appears to be a bug in Sugar pertaining to the Email Settings page in the Admin control panel which may be affecting you. As far as I can tell, just about every version of Sugar from 6.4 to 5.5 have the same problem.

    Anyway, the issue at hand is that it URL decodes some characters before it saves the value. In my case, I stumbled upon the problem because the user name included a "+" symbol. It refused to authenticate although everything was correct. Deeper investigation of the problem revealed that Sugar was saving the "+" as a " " (space). Thus, when it attempted to login to the SMTP server, the login information was indeed wrong because it wasn't sending the "+" symbol. I was fortunate that I could replace the "+" with a "@" but it is something worth looking at if you are using non-alphanumeric values in the user or password portion. It is possible it does the same for other characters.
    Is there any chance this bug (how Sugar filters email address passwords) has other issues?

    I am having the exact ssame symptom:
    - Can go in and enter email passwords and send test email succesfully
    - when save settings and then try to terst again, error

    My email is viua Mailjet and they auto-generate a long UserID and Password string (32 characters, all alpha numeric).

    Is there any chance I have exceeded the character count maximum for the UserID or Password for the emails?

    R

  6. #6
    adam.brunette Guest

    Default Re: Email password not being saved correctly

    Was there any solution to this? I am having the same issue with CE 6.5.11. When I enter the password and test, everything is fine. Once it is saved, it does not work any more.

    Is there any work around that can be implemented?

    -Adam

  7. #7
    Ramblin is offline Sugar Community Member
    Join Date
    May 2010
    Posts
    199

    Default Re: Email password not being saved correctly

    Quote Originally Posted by adam.brunette View Post
    Was there any solution to this?
    -Adam
    Yes,
    In my case it was an erroneous entry in MySQL that had the system looking to the wrong place for the information

    See
    System Email works when initailly enter and test then fails after save

  8. #8
    Alex Bucol Guest

    Default Re: Email password not being saved correctly

    Hello Team,

    I'm new to this and having the same kind of issue.
    We subscribed at sugarondemand.com (CRM URL https://firstcarbon.sugarondemand.com).

    Is there a way I can fix this via the CRM admin portal?

  9. #9
    SimonOBeirne is offline Sugar Community Member
    Join Date
    May 2013
    Posts
    12

    Default Re: Email password not being saved correctly

    We have a similar issue with ampersand (&) characters in passwords, which I suspect is related.

    Found this bug item, looks like it might be fixed pending release?

    bugs.sugarcrm.com/?bug_number=48262

  10. #10
    ppsugar Guest

    Default Re: Email password not being saved correctly

    Hello,
    We have the same issue, that is when I click "Change Password" and type in a password, it works. Then when I save it, it does not work.
    But then Sugar IS able to send emails. For example, if I reset a user's password, he receives the auto-generated password by emails. If I go in user management, choose a user, click on the user's email address to send a quick email, it works.

    The bug I guess is only within the admin panel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 2011-06-16, 10:18 PM
  2. Email Message not seen correctly?
    By arun_raja in forum Help
    Replies: 0
    Last Post: 2009-12-16, 05:28 PM
  3. Replies: 2
    Last Post: 2009-04-09, 12:02 PM
  4. Email template not saving correctly
    By jimwalczak in forum General Discussion
    Replies: 0
    Last Post: 2007-06-27, 04:59 AM
  5. Email URL's not coming through correctly
    By jrhessey in forum Marketing/Campaign Management
    Replies: 6
    Last Post: 2006-12-15, 05:36 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •