Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Errors after installing

  1. #1
    deroos is offline Member
    Join Date
    Dec 2006
    Posts
    7

    Default Errors after installing

    Dear All

    I was trying to install SugarCRM on my (hosted) account and now recieved the following errors when going to http://www.next.lu/crm

    Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 1703 is not allowed to access /home/www/web225/html/next/crm/cache/dynamic_fields owned by uid 30 in /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php on line 804

    Warning: fopen(cache/dynamic_fields/modules.php) [function.fopen]: failed to open stream: No such file or directory in /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php on line 804

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php on line 805

    Warning: fclose(): supplied argument is not a valid stream resource in /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php on line 806

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php:804) in /home/www/web225/html/next/crm/index.php on line 148

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php:804) in /home/www/web225/html/next/crm/index.php on line 148

    Warning: Cannot modify header information - headers already sent by (output started at /home/www/web225/html/next/crm/modules/DynamicFields/DynamicField.php:804) in /home/www/web225/html/next/crm/index.php on line 181

    Thank you very much for your support in trying to get this running!

    All the best & merry X-mas, Daniel.
    Last edited by deroos; 2006-12-25 at 07:44 PM.

  2. #2
    ruchida's Avatar
    ruchida is offline A Sugar Hero | Help Forum Moderator
    Join Date
    Feb 2005
    Location
    Japan
    Posts
    1,376

    Default Re: Errors after installing

    Can you turn off the safe mode in php.ini?
    PHP Code:
    ;
    Safe Mode
    ;
    safe_mode Off 
    Make sure you restart httpd after editing php.ini.

  3. #3
    deroos is offline Member
    Join Date
    Dec 2006
    Posts
    7

    Default Re: Errors after installing

    Dear Ruchida

    Thank you for your response

    I'm affraid I have no access to the php.ini file.
    I used a work-around for the Safe Mode issue I found in the forum by replacing the install/checkSystem.php file.

    Greetings from Switzerland, DaniŽl.

  4. #4
    kpit's Avatar
    kpit is offline A Sugar Hero | Help Forum Moderator
    Join Date
    Dec 2005
    Location
    Memphis, TN
    Posts
    1,004

    Default Re: Errors after installing

    First what is your configuration Webserver, PHP and MySQL versions that you have?
    Cheers,

    Max W. Blackmer, Jr.
    [SIGPIC][/SIGPIC]
    Blog
    Phone: +1 (901) 672-2694



  5. #5
    deroos is offline Member
    Join Date
    Dec 2006
    Posts
    7

    Default Re: Errors after installing

    Dear Max

    Thank you for your response:

    Webserver:

    Hosted Unix Apache Server @ www.dynamic-net.ch
    PHP Version: 4.4.5
    MySQL: Client API version 3.23.49

    Problems I had at step 2 of the installation:

    PHP Safe Mode Turned Off Safe Mode is On (please disable in php.ini)
    Writable Session Save Path (/tmp) Not A Valid Directory

    But after searching through the forum I found a way to work-around this problem by editing the checkSystem.php file.

    Hope this information helps - under http://www.next.lu/crm you can see the above error messages.

    Thank you very much in advance,

    DaniŽl.

  6. #6
    kpit's Avatar
    kpit is offline A Sugar Hero | Help Forum Moderator
    Join Date
    Dec 2005
    Location
    Memphis, TN
    Posts
    1,004

    Default Re: Errors after installing

    I see your problem you are using an older version of MySQL that is not supported. by sugar 4.5.0. It also looks like you have directory permission problems. I would reccomend checking out the wiki for help too.

    http://www.sugarcrm.com/wiki/index.php?title=Main_Page

    You will want to look in the Support area to help you out.
    Cheers,

    Max W. Blackmer, Jr.
    [SIGPIC][/SIGPIC]
    Blog
    Phone: +1 (901) 672-2694



  7. #7
    ruchida's Avatar
    ruchida is offline A Sugar Hero | Help Forum Moderator
    Join Date
    Feb 2005
    Location
    Japan
    Posts
    1,376

    Default Re: Errors after installing

    Quote Originally Posted by deroos
    Dear Max

    Thank you for your response:

    Webserver:

    Hosted Unix Apache Server @ www.dynamic-net.ch
    PHP Version: 4.4.5
    MySQL: Client API version 3.23.49

    Problems I had at step 2 of the installation:

    PHP Safe Mode Turned Off Safe Mode is On (please disable in php.ini)
    Writable Session Save Path (/tmp) Not A Valid Directory

    But after searching through the forum I found a way to work-around this problem by editing the checkSystem.php file.

    Hope this information helps - under http://www.next.lu/crm you can see the above error messages.

    Thank you very much in advance,

    DaniŽl.
    Hi

    Editing checkSystem.php only bypass the step2 task, but never fix the root cause of the error you have.

    The PHP setting your hosting company has is very strict, and I'm afraid SugarCRM won't work.

  8. #8
    deroos is offline Member
    Join Date
    Dec 2006
    Posts
    7

    Default Re: Errors after installing

    Dear Ruchida

    Thank you for your response. I've contacted the hoster to see if they can do anything. What would they need to change?

    Do you know any cheap alternative hosters, where SugarCRM definatively works? Or does maybe would an older version of Sugar CRM - I anyway don't need many of the features - the only important thing is the option to upload attachments.

    Thank you, DaniŽl.


    @ Max - Also thank you for your response. I've looking through the wiki but am affraid I didn't find anything I could use. I only found this showing me that the mySQL version is too low -
    http://www.sugarcrm.com/wiki/index.p...equirements%3F

    However on Step 2 the system didn't complain about the mySQL Version.

    All the best and I'm thankful for any support, DaniŽl.

  9. #9
    ruchida's Avatar
    ruchida is offline A Sugar Hero | Help Forum Moderator
    Join Date
    Feb 2005
    Location
    Japan
    Posts
    1,376

    Default Re: Errors after installing

    Quote Originally Posted by deroos
    Dear Ruchida

    Thank you for your response. I've contacted the hoster to see if they can do anything. What would they need to change?

    Do you know any cheap alternative hosters, where SugarCRM definatively works? Or does maybe would an older version of Sugar CRM - I anyway don't need many of the features - the only important thing is the option to upload attachments.
    Hi

    If your hosting company can disable safe_mode, it will be best. Even under the safe_mode, there are still some other areas which can eliminate restrictions in php.ini, but I can not describe correct settings to make SugarCRM behave correctly under safe_mode.

    I would strongly recommend that you find another company. (because I assume you're not interested in PHP/MySQL configurations....)

    You can find some info here.

  10. #10
    deroos is offline Member
    Join Date
    Dec 2006
    Posts
    7

    Default Re: Errors after installing

    Dear All

    The Safe Mode Problem seems to have been solved by my Hoster:

    http://www.next.lu/crm now works and I get a Login window.

    However after logging the first time I was asked to set the timezone, after doing so, I only got an Internal Server Error and everytime after logging now I recieve the same Internal Server Error.

    Could this be related to the "Writable Session Save Path (/tmp) Not A Valid Directory" Issue

    Thank you for your support!

    DaniŽl.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 8 users browsing this thread. (0 members and 8 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •