Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Fatal error: Allowed memory size

  1. #1
    Pokemahone is offline Member
    Join Date
    Feb 2010
    Posts
    5

    Default Fatal error: Allowed memory size

    Creating Sugar configuration file (config.php)

    Creating Sugar application tables, audit tables and relationship metadata
    .................
    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 77824 bytes) in */subdomains/crm/httpdocs/cache/modules/Employees/Employeevardefs.php on line 350



    I've edited the apropriate ini's including the php.ini, how do I reset my apache webserver from plesk. (8.2.0)
    I don't seem to have any buttons in the system side menu.
    All it says there is;
    - sessions
    - log off

    I have mailed my host and have yet to receive an email back, is there anything I can do myself?

    cheers,

  2. #2
    salesagility's Avatar
    salesagility is offline Sugar Community Member
    Join Date
    Aug 2006
    Location
    UK
    Posts
    2,494

    Default Re: Fatal error: Allowed memory size

    If there's no option to reboot apache, then I'd drop your hosting company another email. You need to be able to reboot in order to implement these changes
    The Open Source Awards are back For 2014

    Check out the open source awards at opensourceawards.org

    Committed to Open Source

    SalesAgility - SugarCRM Community Edition Experts

    Authors of:

    Advanced Open Sales - Quotations, Invoices, Products, PDF Templates and Contracts modules for SugarCRM Community Edition
    Advanced Open Workflow - Workflow for SugarCRM Community Edition
    Advanced Open Events - Events module for SugarCRM Community Edition
    Advanced Open Portal - Portal for SugarCRM Community Edition
    Suite CRM - SugarCRM supercharged!!

  3. #3
    d1m0's Avatar
    d1m0 is offline Senior Member
    Join Date
    Nov 2009
    Posts
    86

    Default Re: Fatal error: Allowed memory size

    When using custom php.ini files, you don't need to restart anything. You simply place the php.ini file in the folder where you need the custom PHP settings to apply and reload the page.

    The webserver has to be restarted only if PHP is running as an Apache module, but in that case you wouldn't place the PHP directives in php.ini files but in an .htaccess file.

    Furthermore, it is possible that your host does not allow custom php.ini files at all.

    Anyway, what are the exact lines you have added to the php.ini file and where have you placed it?
    SiteGround Technical Support Team Member
    Check out our special SugarCRM hosting package

  4. #4
    AlexAv's Avatar
    AlexAv is offline Sugar Community Member
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    933

    Default Re: Fatal error: Allowed memory size

    Hi,

    May be you did wrong changes.

    PHP Code:
    memory_limit 100M      Maximum amount of memory a script may consume 

  5. #5
    Pokemahone is offline Member
    Join Date
    Feb 2010
    Posts
    5

    Default Re: Fatal error: Allowed memory size

    Quote Originally Posted by d1m0 View Post
    When using custom php.ini files, you don't need to restart anything. You simply place the php.ini file in the folder where you need the custom PHP settings to apply and reload the page.

    The webserver has to be restarted only if PHP is running as an Apache module, but in that case you wouldn't place the PHP directives in php.ini files but in an .htaccess file.

    Furthermore, it is possible that your host does not allow custom php.ini files at all.

    Anyway, what are the exact lines you have added to the php.ini file and where have you placed it?

    Code:
    memory_limit = 150M      ; Maximum amount of memory a script may consume (16MB)
    The php.ini is placed in the cgi-bin root of the subdomain, not sure if i need to do anything else.
    I'll give them a call about the custom php.ini but I very much doubt it's that, no email from them today either.
    So I shall call from work in the morning, sofar it still won't let me install sugarcrm.

    Anything else I could look at?

  6. #6
    AlexAv's Avatar
    AlexAv is offline Sugar Community Member
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    933

    Default Re: Fatal error: Allowed memory size

    Maybe system using other php.ini.

    Create a ".php " (info.php) file in the subdomain directory:
    PHP Code:

    echo phpinfo(); 
    Take a look at the memory limit and on the path to php.ini file.

  7. #7
    Pokemahone is offline Member
    Join Date
    Feb 2010
    Posts
    5

    Default Re: Fatal error: Allowed memory size

    Quote Originally Posted by AlexAv View Post
    Maybe system using other php.ini.

    Create a ".php " (info.php) file in the subdomain directory:
    PHP Code:

    echo phpinfo(); 
    Take a look at the memory limit and on the path to php.ini file.
    You just made my day, turns out it uses the php.ini from the "main" site instead of the cgi-bin in the subdomain.
    Thank you so much, this case can be closed as it installed properly after the changes to the real php.ini.

    cheers buddy.

  8. #8
    mad4red is offline Member
    Join Date
    Oct 2010
    Location
    Serbia
    Posts
    8

    Default Re: Fatal error: Allowed memory size

    If you can help me on this.

    I receive next message:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 98304 bytes) in D:\Download\xampplite\htdocs\SugarCE\include\Sugar Objects\templates\person\vardefs.php on line 352

  9. #9
    AlexAv's Avatar
    AlexAv is offline Sugar Community Member
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    933

    Default Re: Fatal error: Allowed memory size

    Quote Originally Posted by mad4red View Post
    If you can help me on this.

    I receive next message:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 98304 bytes) in D:\Download\xampplite\htdocs\SugarCE\include\Sugar Objects\templates\person\vardefs.php on line 352

    You have the same error

    Increase memory limit in your php.ini

    HTML Code:
    memory_limit = 100M  
    After that, restart Web-server

  10. #10
    tshepoth is offline Sugar Community Member
    Join Date
    Jun 2010
    Location
    Pretoria, South Africa
    Posts
    46

    Default Re: Fatal error: Allowed memory size


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fatal error: Allowed memory size
    By Meyer in forum Help
    Replies: 1
    Last Post: 2009-06-25, 10:55 AM
  2. Replies: 7
    Last Post: 2008-04-23, 06:23 AM
  3. PHP Fatal error: Allowed memory size...
    By rousseau in forum Help
    Replies: 3
    Last Post: 2008-03-17, 11:52 PM
  4. PHP Fatal error: Allowed memory size
    By blakegrover in forum Help
    Replies: 1
    Last Post: 2007-06-01, 02:59 PM
  5. Fatal error: Allowed memory size
    By ebox in forum Help
    Replies: 1
    Last Post: 2005-04-07, 06:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •