Page 1 of 4 1234 LastLast
Results 1 to 10 of 32

Thread: i can't upgrade 4.5.0.c to 4.5.0.f

  1. #1
    aguerrave is offline Sugar Community Member
    Join Date
    Apr 2006
    Posts
    31

    Default i can't upgrade 4.5.0.c to 4.5.0.f

    Operating system type and version (i.e. Windows 2000 Server)
    Sugar Suite version (4.5.0c)
    Webserver type and version (Apache 2.0)
    PHP version PHP Version 4.4.3-dev
    MySQL server version (MySQL Version: 3.23.49)

    When i trying to update version i got this error
    Can you help me?
    THK
    Attached Images Attached Images  

  2. #2
    mcichelli is offline Sugar Community Member
    Join Date
    Jun 2006
    Posts
    81

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    I've had this problem for many days now - trying to go from 4.5.0c to d, e, f

    I have been trying to run the upgrade under Windows XP with no luck. I DID get it to work this morning on Windows 2003 - but I don't know why exactly.

  3. #3
    Couchman is offline Sugar Community Member
    Join Date
    Oct 2006
    Posts
    11

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    I have the same problem also. It also happens when I try to install one of the themes.

    To try and resolve this matter I downloaded and tried to upload Sugar Open Source for Microsoft 4.5.0f and when I click upload it just takes me back to my Sugar home page.

    What am I doing wrong?

    Thanks, Tracey

  4. #4
    clint's Avatar
    clint is offline SugarCRM CTO & Co-founder
    Join Date
    Aug 2004
    Location
    Silicon Valley
    Posts
    2,122

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    There was a bug in 4.5.0 through 4.5.0c that causes this problem in some environments.

    The fix is to manually copy the attached uw_utils.php file to your Sugar installation at modules/UpgradeWizard/uw_utils.php.

    Regards,
    Clint
    Attached Files Attached Files
    Sugar Developer Zone - developer resources | Sugar University - user and admin training
    Sugar Docs - user and admin documentation |
    Sugar Bug Tracker - Enter or view bugs
    SugarForge- open source modules, themes, lang packs | SugarExchange - commercial extensions

    Clint Oram
    Chief Technology Officer and Co-founder
    SugarCRM

  5. #5
    Couchman is offline Sugar Community Member
    Join Date
    Oct 2006
    Posts
    11

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    Hi Clint,

    Thanks for that, it worked a treat as far as upgrading is concerned but when I try to install a theme I now get this error message...

    Error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    Should I upload it as a module? I have tried uncompressing it and then recompressing it as a zip file but then it tells me that it's missing a manifest.php file so I guess that isn't the answer!

    Thanks again,

    Tracey

  6. #6
    aguerrave is offline Sugar Community Member
    Join Date
    Apr 2006
    Posts
    31

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    Hi
    sorry but dfonsen'r work, i can upgrade the version, can i try other way?

  7. #7
    mcichelli is offline Sugar Community Member
    Join Date
    Jun 2006
    Posts
    81

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    The replaced php file did not fix the problem.

    I guess I'll stay on Windows 2003 for now.

  8. #8
    clint's Avatar
    clint is offline SugarCRM CTO & Co-founder
    Join Date
    Aug 2004
    Location
    Silicon Valley
    Posts
    2,122

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    What is the behavior everyone is seeing? Is it the PCLZIP PCLZIP_ERR_BAD_FORMAT error?

    When exactly are you seeing this error? What series of clicks did you do to get to this point where you are seeing the error?

    Clint
    Sugar Developer Zone - developer resources | Sugar University - user and admin training
    Sugar Docs - user and admin documentation |
    Sugar Bug Tracker - Enter or view bugs
    SugarForge- open source modules, themes, lang packs | SugarExchange - commercial extensions

    Clint Oram
    Chief Technology Officer and Co-founder
    SugarCRM

  9. #9
    clint's Avatar
    clint is offline SugarCRM CTO & Co-founder
    Join Date
    Aug 2004
    Location
    Silicon Valley
    Posts
    2,122

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    We are thinking it might be a problem with the upgrade_history table. Try running this SQL command and then run the patch upgrade again.

    Code:
       truncate upgrade_history;
    We're storing the absolute path of filename in the upgrade_history table when we previously stored the relative path. If you change paths on the server (which is what the new uw_utils.zip effectively causes to happen), you'll error out during the upgrade wizard with PCL_ZIP errors.

    Clint
    Last edited by clint; 2006-10-31 at 04:10 PM.
    Sugar Developer Zone - developer resources | Sugar University - user and admin training
    Sugar Docs - user and admin documentation |
    Sugar Bug Tracker - Enter or view bugs
    SugarForge- open source modules, themes, lang packs | SugarExchange - commercial extensions

    Clint Oram
    Chief Technology Officer and Co-founder
    SugarCRM

  10. #10
    Couchman is offline Sugar Community Member
    Join Date
    Oct 2006
    Posts
    11

    Default Re: i can't upgrade 4.5.0.c to 4.5.0.f

    Hi,

    To resolve the error reported at the beginning of this thread in the screen shot I edited the php.ini and commented out the line that begins with open_basedir and rebooted.

    After that I was able to upload upgrades without a problem, however, when I try to upload a theme, or any file that ended .gz, I recieve the error message...

    Error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    The ability to upload .zip upgrades remains ok, I just have the problem with uploading .gz files

    I hope this makes things a bit clearer

    Cheers

    Tracey

Page 1 of 4 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •