Results 1 to 7 of 7

Thread: PHP 5.4 Breaks SugarCRM

  1. #1
    morrighu is offline Sugar Community Member
    Join Date
    Apr 2006
    Posts
    35

    Angry PHP 5.4 Breaks SugarCRM

    We normally patch our servers religiously but we have discovered that this breaks the licensing in Sugar Pro. The only fix that we have found is to downgrade PHP from 5.4 to 5.3. My best guess is that it has something to do with REGISTER GLOBALS being removed in 5.4. I am looking for confirmation that you all have plans to address for the next release of Sugar CRM.

  2. #2
    jmertic's Avatar
    jmertic is offline Sugar Community Manager
    Join Date
    Dec 2007
    Posts
    3,996

    Default Re: PHP 5.4 Breaks SugarCRM

    We are looking to add PHP 5.4 support in Sugar 7.
    John Mertic
    Sugar Community Manager

  3. #3
    Kostanos Guest

    Default Re: PHP 5.4 Breaks SugarCRM

    We have the same issue. The only problem it brings with licence validation. The rest of instance is working well.
    Apparently it is not the problem of register_globals, we have it Off in one of our server with 5.3 and the validation works well.

  4. #4
    JimFromAustin Guest

    Default Re: PHP 5.4 Breaks SugarCRM

    I've been doing some research and am finding a lot of people complaining about PHP 5.3.8 and Apache. in specific: php5ts.dll crashes under certain circumstances. I'm not done researching the issue, but I'm getting the distinct impression PHP 5.3.8 is something to be concerned with.

  5. #5
    item is offline Sugar Community Member
    Join Date
    Oct 2010
    Location
    BELGIUM
    Posts
    393

    Default Re: PHP 5.4 Breaks SugarCRM

    I use CE 6.5.12 with 5.4.10 with no error.
    Cheers
    CE 6.2.6 & CE 6.5.14
    Osx Server 10.5.8 & 10.8.2
    Apache - MySql - Php built-in
    I read, i try and i find.... sorry for my good english

  6. #6
    hpsgty Guest

    Default Re: PHP 5.4 Breaks SugarCRM

    We have the same issue. The only problem it brings with licence validation. The rest of instance is working well.

  7. #7
    karmet Guest

    Default Re: PHP 5.4 Breaks SugarCRM

    Quote Originally Posted by jmertic View Post
    We are looking to add PHP 5.4 support in Sugar 7.
    I'm guessing that this is not the case anymore

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Changing root password breaks SugarCRM
    By ldinero in forum Help
    Replies: 3
    Last Post: 2012-02-21, 02:30 AM
  2. Disabling Browser Cache breaks SugarCRM
    By josh.sweeney in forum Developer Help
    Replies: 1
    Last Post: 2008-12-19, 06:47 PM
  3. Replies: 0
    Last Post: 2007-11-14, 02:05 AM
  4. No line breaks in e-mails
    By sunside in forum Help
    Replies: 0
    Last Post: 2005-11-15, 08:37 PM
  5. Flash-upgrade breaks SugarCRM charts
    By softechmatrix in forum General Discussion
    Replies: 2
    Last Post: 2005-11-08, 06:56 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •