Results 1 to 6 of 6

Thread: NL Language Pack installatie probleem (Failed to copy...)

  1. #1
    i-neyo is offline Junior Member
    Join Date
    Mar 2011
    Posts
    2

    Unhappy NL Language Pack installatie probleem (Failed to copy...)

    Beste Sugar experts,

    Ik heb gisteren SugarCRM CE 6.1.3 geinstalleerd (webserver Linux/Apache/MySQL). Na even gestoeid te hebben met de rechten, verliep die installatie voorspoedig.

    Deze ochtend heb ik geprobeerd de nieuwe NL Language Pack (van Prudento) te installeren. Ik heb dit gedaan door via de Module Loader het lokaal op mijn PC opgeslagen Zip bestand te uploaden. De balk waarop de installatievoortgang valt af te lezen blijft echter telkens steken op een armzalige 13%. Als ik vervolgens klik op de onderstaande link [Display Log], valt er het volgende te lezen:

    "Failed to copy /var/www/clients/client0/web51/web/crm/cache/upload/upgrades/temp/yvLUFQ/root to ."

    Nu herken ik alleen het laatste deel van deze regel, en wel vanaf /web/crm/cache/upload/upgrades/temp/...
    Ik heb Sugar namelijk op de webserver geinstalleerd in een subdirectory "crm".
    Het gedeelte daarvoor (/var/www/clients/client0/web51) herken ik niet. Het lijkt in niets op de lokatie waar ik de installatiebestanden op mijn PC heb staan.

    Verder veranderd de naam van de folder "yvLUFQ" (na .../temp/...) - telkens na een hernieuwde installatie poging - in een andere rare naam.

    Vanzelfsprekend heb ik via FTP alle rechten op de files en folders in "cache" zoveel als mogelijk op 777 gezet. Sommige folders, zoals "jsLanguage" blijven echter op 02770 staan.

    Ik ben wat Sugar en PHP betreft een newbie. Ik hoop dan ook dat er onder jullie iemand is die me weer op weg kan helpen.

    Alvast bedankt!
    Peter

  2. #2
    wichard is offline Sugar Community Member
    Join Date
    Dec 2004
    Location
    Almelo, Netherlands
    Posts
    75

    Default Re: NL Language Pack installatie probleem (Failed to copy...)

    De installatie schrijf naar diverse directories, daarvoor moeten de schrijfrechten naar de volgende directories worden aangepast.

    WIJZIGEN:

    chmod 777 themes/default/images

    chmod 777 jscalendar/lang

    chmod 777 include/images

    chmod 777 include/language

    chmod 777 include/phpmailer/language
    #bestand bestaat dus niet overschrijfbaar!
    chmod 777 include/phpmailer/language/phpmailer.lang-nl.php

    chmod 777 include/SugarFields/Fields/Address

    chmod 777 include/SugarObjects/implements/assignable/language
    chmod 777 include/SugarObjects/implements/team_security/language

    chmod 777 include/SugarObjects/templates/basic/language

    chmod 777 include/SugarObjects/templates/company/language

    chmod 777 include/SugarObjects/templates/company/language/application
    chmod 777 include/SugarObjects/templates/file/language
    chmod 777 include/SugarObjects/templates/file/language/application
    chmod 777 include/SugarObjects/templates/issue/language
    chmod 777 include/SugarObjects/templates/issue/language/application
    chmod 777 include/SugarObjects/templates/person/language
    chmod 777 include/SugarObjects/templates/sale/language
    chmod 777 include/SugarObjects/templates/sale/language/application

    chmod 777 install/language

    chmod 777 jscalendar/lang
    chmod 777 jscalendar/lang/calendar-nl.js

    Laat maar weten of je nog problemen ondervind als je bovenstaande hebt aangepast en de installatie opnieuw probeert
    Wichard Noppert
    Prudento
    Twitter

  3. #3
    i-neyo is offline Junior Member
    Join Date
    Mar 2011
    Posts
    2

    Smile Re: NL Language Pack installatie probleem (Failed to copy...)

    Dankjewel Wichard! Installatie is nu gelukt.
    Moet ik alle rechten nu zo laten staan (777), of kan ik ze terugzetten naar bijvoorbeeld 755?

  4. #4
    wichard is offline Sugar Community Member
    Join Date
    Dec 2004
    Location
    Almelo, Netherlands
    Posts
    75

    Default Re: NL Language Pack installatie probleem (Failed to copy...)

    Mooi dat het gelukt is, de extra kun je wel terugzetten naar 755, het is alleen nodig tijden de installatie zodat in de directories bestanden kunnen worden toegevoegd of overschreven. Bij een volgende installatie van het Nederlandse languagepack moet het wel weer beschrijfbaar zijn.
    Wichard Noppert
    Prudento
    Twitter

  5. #5
    ebogaard is offline Sugar Community Member
    Join Date
    Jun 2011
    Posts
    28

    Default Re: NL Language Pack installatie probleem (Failed to copy...)

    Ook ik heb problemen met het Nederlandse languagepack. Ik gebruik Sugar 6.1.6 en installatie van het languagepack lijkt prima te werken, want geen foutmeldingen in de log. Als het scherm dan is ververst, is alles nog steeds in het Engels.

    Ook als ik NL handmatig toevoeg aan config.php en bij het inloggen daarvoor kies, is alles nog in het Engels. Geprobeerd alle rechten aan te passen zoals in dit topic beschreven, maar helaas zonder resultaat.

    Zou het iets te maken kunnen hebben met de volgende meldingen in sugarcrm.log:

    Code:
    Mon Jun 20 14:03:20 2011 [30130][1][FATAL] HTTP Error: no data present after HTTP headers
    Mon Jun 20 14:03:20 2011 [30130][1][FATAL] HTTP/1.1 100 Continue^M
    ^M
    HTTP/1.1 500 Internal Server Error^M
    Server: nginx^M
    Date: Mon, 20 Jun 2011 12:03:20 GMT^M
    Content-Type: text/html^M
    Connection: keep-alive^M
    X-Application-Server: 10.13.10.129^M
    Content-Length: 0^M
    ^M
    
    Mon Jun 20 14:03:21 2011 [30130][1][FATAL] HTTP Error: no data present after HTTP headers
    Mon Jun 20 14:03:21 2011 [30130][1][FATAL] HTTP/1.1 500 Internal Server Error^M
    Server: nginx^M
    Date: Mon, 20 Jun 2011 12:03:21 GMT^M
    Content-Type: text/html^M
    Connection: keep-alive^M
    X-Application-Server: 10.13.10.129^M
    Content-Length: 0^M
    Bedankt alvast!


    Update: het is nu gelukt door gebruik te maken van een http i.p.v. een https-verbinding. Weet niet wat daar de oorzaak van is, maar dat zoek ik nog wel uit.
    Wel vreemd, is dat de SugarCRM starpagina nu helemaal leeg is en er ook geen knoppen zijn voor het toevoegen van Dashlets e.d..
    Iemand daar suggesties voor?

    Update2: Ook dat is opgelost. In config.php nu als standaardtaal nl_NL gezet i.p.v. nl_nl.
    Last edited by ebogaard; 2011-06-20 at 12:32 PM.

  6. #6
    dspaan is offline Junior Member
    Join Date
    Feb 2011
    Posts
    9

    Default Re: NL Language Pack installatie probleem (Failed to copy...)

    Hallo ik heb Sugar CRM 6.4.6 (Build 7791) geinstalleerd en ook het Nederlandse taalpakket getracht te installeren. Bij mij komt de installatie tot 100% maar lukt toch niet. Hier de log:

    Installing administration extension
    Installing Language Packs
    Rebuilding Language...nl_NL
    Rebuilding Language...en_us
    Warning: This script isn't in the allowed_admin_path setting! in /srv/www/htdocs/sugar_cco/sugarcrm2/include/SugarCache/SugarCache.php on line 121 Rebuilding ActionViewMap...
    Rebuilding ActionFileMap...
    Rebuilding ActionReMap...
    Rebuilding Administration...
    Rebuilding EntryPointRegistry...
    Rebuilding Extensions...
    Rebuilding FileAccessControlMap...
    Warning: This script isn't in the allowed_admin_path setting! in /srv/www/htdocs/sugar_cco/sugarcrm2/include/SugarCache/SugarCache.php on line 121 Rebuilding Layoutdefs...
    Rebuilding GlobalLinks...
    Rebuilding LogicHooks...
    Rebuilding Menus...
    Rebuilding Include...
    Rebuilding ScheduledTasks...
    Rebuilding UserPage...
    Rebuilding Utils...
    Rebuilding Vardefs...
    Warning: This script isn't in the allowed_admin_path setting! in /srv/www/htdocs/sugar_cco/sugarcrm2/include/SugarCache/SugarCache.php on line 121 Warning: This script isn't in the allowed_admin_path setting! in /srv/www/htdocs/sugar_cco/sugarcrm2/include/SugarCache/SugarCache.php on line 121
    Enige hulp wordt zeer gewaardeerd.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Probleem bij installatie taalbestand
    By Huub van der Linden in forum Dutch
    Replies: 4
    Last Post: 2009-10-17, 03:07 PM
  2. Replies: 1
    Last Post: 2009-04-14, 10:09 PM
  3. Language pack NL installatie
    By Tonk in forum Dutch
    Replies: 6
    Last Post: 2009-04-10, 11:56 AM
  4. installatie probleem language pack
    By Silentracer in forum Dutch
    Replies: 4
    Last Post: 2008-09-30, 07:04 PM
  5. Language Pack installation failed
    By Philippsen in forum Installation and Upgrade Help
    Replies: 3
    Last Post: 2007-02-14, 11:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •