Results 1 to 3 of 3

Thread: How do you Install a Language Pack in SugarCRM

  1. #1
    ld_florida Guest

    Default How do you Install a Language Pack in SugarCRM

    Hello Everyone,

    I'm having trouble adding a language pack. I've looked in the documentation but it simply says: "Load the Language Pack from your machine to Sugar." The question is: How do you do this? What specific file should you upload via Module Loader to get the language pack to work?

    I'm running SugarCRM Version 6.4.3 (Build 7673) and I'm trying to install the Spanish language pack. I've tried to install several different versions - nothing works.

    Every file that I try to upload using Module Loader return the same error: Invalid Package. I've tried uploading the following files from my local machine:

    1) \SugarEnt-6.4.3-lang-sp_ve\manifest.php
    2) \SugarEnt-6.4.3-lang-sp_ve\include\language\sp_ve.lang.php
    3) \SugarEnt-4.5.1e-lang-es_es-20070709\manifest.php
    4) \SugarEnt-4.5.1e-lang-es_es-20070709\install\language\es_es.lang.php
    5) SugarEnt-6.4.3-lang-sp_ve.zip


    In the case of the Spanish version, which version should I use? (the 6.4.3 version seems to be incomplete, comparing it to previous versions). Has anyone been able to install the Spanish language pack successfully on v. 6.4.3?

    Thanks for your help!

    (I've tried posting this in other areas but have yet to receive a response. Hopefully the question will be seen by more users here.)

  2. #2
    sts's Avatar
    sts
    sts is offline Sugar Community Member
    Join Date
    Aug 2010
    Location
    Germany
    Posts
    1,539

    Default Re: How do you Install a Language Pack in SugarCRM

    With module loader you always have to load installation packages which are files in zip-format (so no. 5 of your list looks like it should be the right one to choose). This installation package must contain manifest.php file plus plus several other files and directories which depends on the content of the manifest file.

    The manifest file contains two settings that might be the problem in your case: one is for the sugar edition(s) ("acceptable_sugar_flavors") and one for the release(s) ("acceptable_sugar_versions") for which this installation package has been made (or tested). If CE (I assume you are using CE) is not allowed or 6.4 or 6.4.3 is not allowed in that settings the module builder will show you the error message you mentioned [Here a link to a manifest file documentation: Atcore Systems - SugarCRM Manifest Development Guide]. There might be other reasons for the message too, but those are typical for that.

    So you should check if you are using the correct version of installation package. If yes you should have a look into the manifest file inside the zip and check the two settings I mentioned. Maybe there is something wrong.
    Stefan Ulrich Sauer
    System Analyst

    Devoteam GmbH
    Gutenbergstraße 10
    D-64331 Weiterstadt
    Germany
    email: Stefan-Ulrich.Sauer@devoteam.com
    http://www.devoteam.com
    http://www.devoteam.de

  3. #3
    ld_florida Guest

    Default Re: How do you Install a Language Pack in SugarCRM

    Quote Originally Posted by sts View Post
    So you should check if you are using the correct version of installation package. If yes you should have a look into the manifest file inside the zip and check the two settings I mentioned. Maybe there is something wrong.
    Thank you so much for your detailed reply Stefan, that solved the problem!

    We were using an incorrect version of the language pack. Incidentally, if anyone's using SugarCRM CE 6.4.3 the spanish pack is here: http://www.sugarforge.org/frs/downlo...lang-sp_ve.zip

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 2012-05-18, 05:15 PM
  2. Can't install language pack FR
    By dsr in forum Translators
    Replies: 3
    Last Post: 2010-01-20, 09:44 PM
  3. No way to install language pack
    By vibarco in forum Installation and Upgrade Help
    Replies: 19
    Last Post: 2009-09-28, 02:45 PM
  4. how to install a language pack
    By kaos in forum Help
    Replies: 4
    Last Post: 2006-07-26, 03:48 PM
  5. Install language pack
    By stefano.schifano in forum Translators
    Replies: 1
    Last Post: 2006-05-31, 05:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •