Results 1 to 7 of 7

Thread: Run Sugar on a different port of MySQL

  1. #1
    roston is offline Member
    Join Date
    Sep 2005
    Posts
    5

    Question Run Sugar on a different port of MySQL

    Does anyone perhaps know how to run sugar crm on a different MySQL port? e.g. 3307???

  2. #2
    nicolas is offline Sugar Community Member
    Join Date
    Apr 2005
    Posts
    74

    Default Re: Run Sugar on a different port of MySQL

    If your host is localhost, you can set in config.php
    db_host_name='localhost:3307'
    You can also use a socket
    localhost:/path_to_socket/mysocket.sock

    Nicolas

  3. #3
    roston is offline Member
    Join Date
    Sep 2005
    Posts
    5

    Default Re: Run Sugar on a different port of MySQL

    Thanks for the quick reply. Do you perhaps know of a way from the install wizard?

  4. #4
    nicolas is offline Sugar Community Member
    Join Date
    Apr 2005
    Posts
    74

    Default Re: Run Sugar on a different port of MySQL

    The same way, when it ask you the db host, set it to
    localhost:3307

  5. #5
    roston is offline Member
    Join Date
    Sep 2005
    Posts
    5

    Post Re: Run Sugar on a different port of MySQL

    Hi There

    Ok I've tried that now I get this error.

    Database admin user name and/or password is invalid (Error 2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)).

    see attached file.

    Cheers
    Attached Images Attached Images  

  6. #6
    nicolas is offline Sugar Community Member
    Join Date
    Apr 2005
    Posts
    74

    Default Re: Run Sugar on a different port of MySQL

    Have you granted access to the 'sugarcrm' database to the 'sugarcrm' user (name diplayed in your screenshot) ?
    Errors like that are always due to a bad configuration of the mysql server (like user privileges) or an error on writing password ...
    And why do you create a sugarcrm user ?
    You have many database on your mysql server on port 3307?

    I hope it'll help you ...

    Nicolas

    PS :
    for the port : I use 2 mysql server, one for ... and an other for sugar .
    I don't use another port but a socket. If your application and mysql server are running on the same server, try to start your mysql server with a socket, and fill hostname in sugar with :
    localhost:/path_to_socket/mysocket.sock
    It'll work easily
    Last edited by nicolas; 2005-09-21 at 10:22 PM.

  7. #7
    swafran72 is offline Junior Member
    Join Date
    Jan 2008
    Posts
    1

    Default Re: Run Sugar on a different port of MySQL

    I had the same problem, needed to run sugar using a mysql server listening on port 3307. Using the community php install script, there was no option to specify a mysql port during install and plugging in localhost:3307 for host did not work.

    I added the following to install.php and include/entryPoint.php. Install went smooth, everything looks good. I'll repost if I have any trouble. Seems to work.

    ini_set('mysqli.default_socket', '/tmp/mysql5.sock');

    You need to change '/tmp/mysql5.sock' to whatever info your server jocks give you for the socket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •