Results 1 to 3 of 3

Thread: Task received URL incorrect in email received

  1. #1
    waylander is offline Junior Member
    Join Date
    Mar 2006
    Posts
    1

    Question Task assigned email received has incorrect URL to sugar location

    The email sent when a task is assigned to a user displays the incorrect URL for accessing our installation of Sugar:

    URL in task mail:

    Jane Doe has assigned a Task to John Doe.

    Subject: Sugar Fix
    Priority: In Progress
    Due Date:
    Status: In Progress
    Description:

    You may review this Task at:<http://myserver:8000/sugarcrm:8000/index.php?module=Tasks&action=DetailView&record=.. ....>

    But it should be:

    <http://myserver:8000/sugarcrm/index.php?module=Tasks&action=DetailView&record=.. .....>

    The account settings are correct in the Admin module for all users:

    Account settings:

    URL: http://myserver:8000/sugarcrm - Use this URL when establishing login settings for the Sugar Plug-in for Microsoft Outlook and the Sugar Plug-in for Microsoft Word.

    For some reason, an extra port 8000 is added after the sugarcrm folder. Anyone else run into this issue or have any ideas on how this can be fixed? It isn't a major issue, just have a few irritated users who when clicking on their URLs in the email are tired of serring a page not found error.

    I have just updated to v4.0.1e but it looks like it has been evident for a while, but it has only recently been brought to my attention

    Thanks
    Last edited by waylander; 2006-03-16 at 02:16 PM.

  2. #2
    sugarchris's Avatar
    sugarchris is offline Sugar Community Member
    Join Date
    Sep 2005
    Location
    San Francisco, CA
    Posts
    861

    Default Re: Task received URL incorrect in email received

    Valid bug. I'll take it from here (since I "fixed" this in a prior release).
    Thanks for the detailed description - it really helps when diagnosing.

    If you'd like to fix this (for yourself, or anyone seeing an identical situation) you can apply the following change in ./data/SugarBean.php ~line 891
    PHP Code:
    ...
             if(isset(
    $_SERVER['SERVER_PORT']) && $_SERVER['SERVER_PORT'] != 80) {
                 
    //$port = ':'.$_SERVER['SERVER_PORT'];
             

    Comment out the $port = ... line.
    Last edited by sugarchris; 2006-03-16 at 07:35 PM.

  3. #3
    ogomez is offline Sugar Community Member
    Join Date
    Jul 2006
    Posts
    25

    Default Re: Task received URL incorrect in email received

    Testing here 4.5.1, Build 1197 (sorry if this has been fixed later)

    I have one question: what is (and what is NOT) the $sugar_config['site_url'] parameter for?

    I have the same problem but in a proxied environment (the real host running sugar is behind a firewall, and has only a private ip, accesed by mod_proxy). I set in site_url the real url base (so everyone can access), but this is broken with the "autodetection". My diff is this:

    < $host = (!$parsedSiteUrl['host']) ? $httpHost : $parsedSiteUrl['host'];
    ---
    > $host = ($parsedSiteUrl['host'] != $httpHost) ? $httpHost : $parsedSiteUrl['host'];


    I'm still testing this solution, but at least this stores in $host the real working url, not the internal host ip, not valid from outside.

    If the site_url parameter is NOT intended for this use, then I suggest to create another parameter or assign the site_url parameter this use (at lest for notifications, etc).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •