Results 1 to 8 of 8

Thread: Blank Response in LinkedIn connector

  1. #1
    dhavaldarji's Avatar
    dhavaldarji is offline Sugar Community Member
    Join Date
    Mar 2012
    Posts
    115

    Default Blank Response in LinkedIn connector

    Hi All,
    Using SugarCE - 6.5.9 (Build 8653)
    I am having issue with linked in connector, when i click on "in" icon in Account detail page, it have blank response and the popup is empty.
    When i checked js errors it says "Uncaught ReferenceError: LinkedIn is not defined" and having error executing linkedin script :
    Refused to execute script from 'http://www.linkedin.com/companyInsider?script&useBorder=no' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

    Using google chrome 28.0.1500.71.

    See the attached screenshot.
    Name:  LinkedInScriptError.png
Views: 499
Size:  104.4 KB

    This seems to be working with other sugar instance, with same version and same browser

    Any idea?
    Regards,
    Dhaval Darji

  2. #2
    dhavaldarji's Avatar
    dhavaldarji is offline Sugar Community Member
    Join Date
    Mar 2012
    Posts
    115

    Default Re: Blank Response in LinkedIn connector

    Hey All,

    Finally, jQuery at rescue ...! ($.getScript())

    Copied the default tpl file for linkedIn connector to custom/modules/Connectors/connectors/formatters/ext/rest/linkedin/tpls/default.tpl from modules/Connectors/connectors/formatters/ext/rest/linkedin/tpls/default.tpl.

    Changed these line :
    Code:
    {*<script src="{if $smarty.server.HTTPS === 'on'}index.php?entryPoint=get_url&type=linkedin{else}{{$config.properties.company_url}}{/if}" type="text/javascript"></script>*}
    <script type="text/javascript">
    $.getScript("{if $smarty.server.HTTPS === 'on'}index.php?entryPoint=get_url&type=linkedin{else}{{$config.properties.company_url}}{/if}");
    </script>
    And done
    Regards,
    Dhaval Darji

  3. #3
    jayrb is offline Sugar Community Member
    Join Date
    Dec 2007
    Posts
    58

    Default Re: Blank Response in LinkedIn connector

    Hi,

    I've got the same issue and I tried the above instruction with no result. I did a Quick Rebuild and enabled Developer Mode, so the change should be live.

    To be clear on the change, I removed the line:
    Code:
    {*<script src="{if $smarty.server.HTTPS === 'on'}index.php?entryPoint=get_url&type=linkedin{else}{{$config.properties.company_url}}{/if}" type="text/javascript"></script>*}
    and replaced it with:
    Code:
    <script type="text/javascript">
    $.getScript("{if $smarty.server.HTTPS === 'on'}index.php?entryPoint=get_url&type=linkedin{else}{{$config.properties.company_url}}{/if}");
    </script>
    Did I do it correctly?

    Jay

    Sugar Pro 6.5.14 (Build 1055)
    Amazon Linux AMI

  4. #4
    ebogaard is offline Sugar Community Member
    Join Date
    Jun 2011
    Posts
    28

    Default Re: Blank Response in LinkedIn connector

    I'm struggling with this too. The LinkedIn-connector doesn't work in modern browsers anymore, which block mixed-content (http-requests when using https) by default.
    LinkedIn wants you to go to use their API, so it doesn't offer an https-version of the CompanyInsider-URL and redirects you if you try to use it. Hence the blank response and the error in Web Developer tools.
    I tried to setup a reverse https-proxy for the LinkedIn URL, but that doesn't seem to work.

    Does anyone else have an idea how to fix this?

  5. #5
    chad@presentcreative.com Guest

    Default Re: Blank Response in LinkedIn connector

    I'm also running across this issue. We're using a web deployed version, Sugar Professional Version 6.7.2 (Build 1118). Also checked my js window and I'm getting the same errors. Since I'm on the web-deployed version, I don't think I'm able to do any fancy scripting around the issue, and I'm not really all that comfortable scripting anyway.

    We just purchased SugarCRM two weeks ago and this is kind of a major bummer for us. Isn't this functionality supposed to work right out of the box?

    Any solutions?

  6. #6
    chad@presentcreative.com Guest

    Default Re: Blank Response in LinkedIn connector

    As another interesting side-note... I noticed that if I'm not logged in to LinkedIn, then the pop up window is not-blank and asks me to sign in. Once I've signed in to LinkedIn, blank window. Seems like my credentials aren't getting passed. Additional info... I'm on a Mac, running the lastest versions of both Chrome and Firefox. Version 25.0.1364.155 and 23.0.1 respectively.

  7. #7
    chad@presentcreative.com Guest

    Default Re: Blank Response in LinkedIn connector

    Hi, I keep replying to this thread, but the Admins don't seem to be letting my posts through.

    I'm also having trouble with this and it seems like LinkedIn has changed the method to call the relevant URL. It says EXPLICITLY in the setup that there is no need to change the URL unless LinkedIn changes the URL. Sooooo they have. Can we get some assistance here please?

  8. #8
    dkallish@sugarcrm.com Guest

    Default Re: Blank Response in LinkedIn connector

    Hello chad@presentcreative.com,

    I don't believe this has been 'officially' stated anywhere, but LinkedIn has decided to no longer work with SugarCRM, at the present time at least. Our Engineering Team and LinkedIn's Team are working together, but at this time we're awaiting information from LinkedIn.

    Kind regards,

    Dan Kallish
    SugarCRM Technical Support Engineer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Whats the point of the LinkedIn connector ?
    By vocality in forum General Discussion
    Replies: 24
    Last Post: 2013-05-08, 04:52 AM
  2. We Need A LinkedIn Connector Custom Solution
    By globalogicom in forum Classifieds
    Replies: 15
    Last Post: 2011-09-21, 04:34 PM
  3. Using LinkedIn Connector Effectively
    By markb14391 in forum Help
    Replies: 4
    Last Post: 2010-09-13, 09:10 AM
  4. LinkedIn connector Field Mapping
    By contact-ts in forum Customer Support
    Replies: 1
    Last Post: 2009-10-28, 12:45 PM
  5. LinkedIn Connector
    By robtarr in forum Installation and Upgrade Help
    Replies: 2
    Last Post: 2009-03-27, 05:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •